Page 1 of 1

Keyboard slowing down boot process over 20 secs

PostPosted: Tue Jun 06, 2017 1:38 pm
by Roland
I noticed a strange thing when I tested booting without my keyboard connected... The X5000 booted over 20 secs faster without the keyboard connected than with it! And it was the boot animation which was affected: it run much faster when the Keyboard was unplugged. What was most pecular, disconnecting the keyboard during the animation slowed it further, instead of making it to run faster?!

My keyboard is a Ducky One. Is it the same for all keyboards...?

- Roland -

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Fri Jun 16, 2017 11:01 pm
by Ribdevil
Roland wrote:I noticed a strange thing when I tested booting without my keyboard connected... The X5000 booted over 20 secs faster without the keyboard connected than with it! And it was the boot animation which was affected: it run much faster when the Keyboard was unplugged. What was most pecular, disconnecting the keyboard during the animation slowed it further, instead of making it to run faster?!

My keyboard is a Ducky One. Is it the same for all keyboards...?

- Roland -


In my system yes.
But I have a keyboard that the anim in UBOOT is fast, but don't let me go to boot menu, and the clock don't work.
My UBOOT is 2014.04 (Oct

I think we have similar problems. And it's a HARDWARE PROBLEM, or drivers in UBOOT. :(

Virginio

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Sat Jun 17, 2017 3:46 pm
by Roland
Ribdevil wrote:
Roland wrote:I noticed a strange thing when I tested booting without my keyboard connected... The X5000 booted over 20 secs faster without the keyboard connected than with it! And it was the boot animation which was affected: it run much faster when the Keyboard was unplugged. What was most pecular, disconnecting the keyboard during the animation slowed it further, instead of making it to run faster?!

My keyboard is a Ducky One. Is it the same for all keyboards...?

In my system yes.
But I have a keyboard that the anim in UBOOT is fast, but don't let me go to boot menu, and the clock don't work.
My UBOOT is 2014.04 (Oct


Thanks for confirming this... I have the same U-Boot version. How about other X5000 users, can you tell whether the keyboard affects the speed of boot animation? In my case the difference is very clear, the ten 'flashes' go with very short intervals when the keybord is not conncted.

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Sun Jun 18, 2017 3:56 am
by daveyw
I have a mechanical keyboard from WASDKeyboards.

The Boing Ball in the boot anim spins really fast when its not plugged in!

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Sun Jun 18, 2017 2:23 pm
by Roland
daveyw wrote:I have a mechanical keyboard from WASDKeyboards.

The Boing Ball in the boot anim spins really fast when its not plugged in!


Ok, thanks for this info... So It seems this is a problem (or "feature") of all Cyrus+ boards. Not a big deal in normal use, but quite annoying when you are 'debugging' something and have to reboot regularly... Let's hope there will be some fix for this in future.

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Sun Jun 18, 2017 6:05 pm
by xenic
Roland wrote:
daveyw wrote:I have a mechanical keyboard from WASDKeyboards.

The Boing Ball in the boot anim spins really fast when its not plugged in!


Ok, thanks for this info... So It seems this is a problem (or "feature") of all Cyrus+ boards. Not a big deal in normal use, but quite annoying when you are 'debugging' something and have to reboot regularly... Let's hope there will be some fix for this in future.


I don't have an X5000 yet but was wondering if unplugging the mouse or mouse & keybord has any effect.

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Mon Jun 19, 2017 10:12 am
by Roland
xenic wrote:I don't have an X5000 yet but was wondering if unplugging the mouse or mouse & keybord has any effect.


With mouse (A-Eon BoingBall MV 1000-1) I have not noticed any problems or effects on boot process, it is only the Keyboard. There are also problems with text input, but that topic deserves a new thread...

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Mon Jun 19, 2017 12:12 pm
by broadblues
@Roland

Have you tried with a more generic keyboard?

Re: Keyboard slowing down boot process over 20 secs

PostPosted: Mon Jun 19, 2017 2:14 pm
by Roland
broadblues wrote:@Roland
Have you tried with a more generic keyboard?


Not yet... As X5000 is my first machine with USB, I do not have any old peripherals around. Have to wait until I can borrow something to test... On the other hand, as I bought this expensive 'Loriano keyboard' especially for X5000, I would naturally like to use it :-). As Duckies has been used for a long time with X1000s, I suppose also the X5000 software will be fixed to work properly with them.