USB Power

AmigaOne X5000 platform specific issues.

USB Power

Postby xenic » Mon Aug 28, 2017 11:39 pm

I use a WIFI network adapter that is plugged into my network card and a USB port for power. On my X1000 the adapter powers up and has established the connection to my router by the time AmigaOS is booted and ready to use. My X5000 cuts power to the USB port several times during the boot process and the network adapter attempts a connection each time the USB power is restored (sometimes succeeding) but then takes a long time to reconnect when the USB power is finally restored for good. Whenever I perform a warm reboot on my X1000, the adapter stays connected to the router and is ready when AmigaOS is booted. The X5000 kills the USB power during a warm reboot and I have to wait for the WIFI adapter to get a connection.

Is there a UBOOT setting that can be set or a jumper that can be changed to eliminate cutting the USB power after turning the system on. Surely cutting the power multiple times can't be good for wireless mice and keyboards. It's probably why my wireless mouse didn't work properly until I plugged it in through an unpowered HUB.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1020
Joined: Sun Jun 19, 2011 1:06 am

Re: USB Power

Postby Rigo » Tue Aug 29, 2017 3:01 am

You could always use one of those wall adapters which most mobile phones come with nowadays....

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 324
Joined: Mon Jan 17, 2011 10:42 pm

Re: USB Power

Postby xenic » Tue Aug 29, 2017 3:19 pm

Rigo wrote:You could always use one of those wall adapters which most mobile phones come with nowadays....
Simon

That's the least desirable alternative because the WIFI adapter doesn't have a power switch. Even if it had a switch, starting my X5000 would feel more like the countdown to a missile launch: 10 9 activate computer, 8 7 activate monitor, 6 5 activate speakers, 4 3 activate WIFI adapter, 2 1 0, lift-off.

I just wanted to see if there was a simple way to avoid having the USB power switching on and off multiple times.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1020
Joined: Sun Jun 19, 2011 1:06 am

Re: USB Power

Postby icbrkr » Sat Sep 02, 2017 11:08 pm

Yup, I was noticing the same problem.


I have an IOGear Wifi bridge since there aren't any reliable drivers to do wireless and if the adapter comes up 'later', the TCP/IP stack doesn't get an IP from it which requires me to reboot or restart the networking.

I ended up doing just what was mentioned though I'm not thrilled by it either - I have a USB power supply for now.
icbrkr
 
Posts: 17
Joined: Wed Aug 02, 2017 5:57 pm

Re: USB Power

Postby Amigo1 » Tue Sep 05, 2017 8:11 pm

xenic wrote:
Rigo wrote:You could always use one of those wall adapters which most mobile phones come with nowadays....
Simon

That's the least desirable alternative because the WIFI adapter doesn't have a power switch. Even if it had a switch, starting my X5000 would feel more like the countdown to a missile launch: 10 9 activate computer, 8 7 activate monitor, 6 5 activate speakers, 4 3 activate WIFI adapter, 2 1 0, lift-off.

I just wanted to see if there was a simple way to avoid having the USB power switching on and off multiple times.


You could try something like this:

http://www.ebay.com/itm/NZXT-Internal-U ... SwOuRZqNUb

it's an internal USB Hub, it uses power from the PSU and you can connect the front panel USB and use 2 internal USB ports on the small board.

The following one seems to be the the upgraded/new model

https://www.nzxt.com/products/internal-usb-hub

edit: I'm using one one the AmigaOne-XE and AmigaOne X1000 so I have all 4 Front-USB ports of the computer case connected.
User avatar
Amigo1
 
Posts: 156
Joined: Sun Jan 01, 2012 4:32 pm

Re: USB Power

Postby xenic » Wed Sep 06, 2017 12:19 am

Amigo1 wrote:
You could try something like this:

http://www.ebay.com/itm/NZXT-Internal-U ... SwOuRZqNUb

it's an internal USB Hub, it uses power from the PSU and you can connect the front panel USB and use 2 internal USB ports on the small board.

The following one seems to be the the upgraded/new model

https://www.nzxt.com/products/internal-usb-hub

edit: I'm using one one the AmigaOne-XE and AmigaOne X1000 so I have all 4 Front-USB ports of the computer case connected.

I appreciate your help with another workaround but I can always get out the dirll and soldering iron and add a power plug or a usb connector that only supplies power. I've already have a number of workarounds for other things on my X5000 and was hoping I wouldn't need a USB workaround. I'm hoping there is a jumper or UBOOT setting to avoid having the USB power down several times during the initial boot process and when I perform a soft reboot. The power down is affecting more than just my WIFI adapter. I have an HP Photosmart printer that has a USB socket that I keep a flash drive plugged into so I can scan to the flash drive. My printer is going through multiple restarts when the USB port power goes on and off and flash drive on the printer is only occasionally getting mounted by OS4 as a result. It also has a negative impact on the 3 wireless mice I've tried; they frequently don't get mounted properly. I wonder who decided it was a good idea to have the USB power going on and off.

Maybe I'll need to contact A-EON to find out if there is a way to disable the USB power off and on.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1020
Joined: Sun Jun 19, 2011 1:06 am


Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 1 guest

cron