Early startup menu?

AmigaOne X5000 platform specific issues.

Early startup menu?

Postby esc » Fri Dec 08, 2017 9:06 am

Hey guys, how do I access the early startup menu? Is there some special time when pressing escape reliably works? I've tried holding it down and that works but makes the bootup menu unusable. Any ideas?
esc
 
Posts: 30
Joined: Sun Oct 25, 2015 7:38 pm

Re: Early startup menu?

Postby smf » Fri Dec 08, 2017 9:16 am

Hi!
i assume you mean the "early startup menu" in Uboot?
Press "Esc" when boot picture animation starts.
Do not press esc before the animation starts.
smf
Beta Tester
Beta Tester
 
Posts: 93
Joined: Fri Nov 18, 2011 12:16 am

Re: Early startup menu?

Postby esc » Fri Dec 08, 2017 9:32 am

Thanks! Still having some problems for some reason. Is it a press-and-hold, or a press-over-and-over-again, or press-just-after-the-animation-starts-and-wait?

:)
esc
 
Posts: 30
Joined: Sun Oct 25, 2015 7:38 pm

Re: Early startup menu?

Postby smf » Fri Dec 08, 2017 9:37 am

Press once when the animation begins :)

Is it unreliable or doesn't work at all?
smf
Beta Tester
Beta Tester
 
Posts: 93
Joined: Fri Nov 18, 2011 12:16 am

Re: Early startup menu?

Postby esc » Fri Dec 08, 2017 9:41 am

I have gotten to the menu a handful of times but usually by hitting the escape key over and over again as fast as possible, which renders it useless. I am using a KVM and an Apple USB keyboard, I wonder if that has something to do with it :(
esc
 
Posts: 30
Joined: Sun Oct 25, 2015 7:38 pm

Re: Early startup menu?

Postby esc » Fri Dec 08, 2017 10:08 am

By the way, the error message is "Timeout poll on interrupt endpoint"
esc
 
Posts: 30
Joined: Sun Oct 25, 2015 7:38 pm

Re: Early startup menu?

Postby esc » Wed Dec 20, 2017 12:05 am

Does anyone know where X5000 bugs should be filed?
esc
 
Posts: 30
Joined: Sun Oct 25, 2015 7:38 pm

Re: Early startup menu?

Postby tonyw » Wed Dec 20, 2017 10:51 am

Try it without the KVM switch. At the time you are trying to interrupt the U-Boot boot sequence, it is U-Boot that is running, and it has known issues with USB hubs, KVMs etc. It's not an X-5000 or an OS4 problem and U-Boot is not likely to be reworked for such a minor problem in such a small market. It's an emergency boot console, nothing more.

To get U-Boot's attention, just wait until the ball shoots and starts to spin, then type *any* key (once is enough). That will get you to the menu (list of six options, of which "Command Line" is the last). Each option has a single-letter shortcut (eg "M" for "Command Line". I don't know how long you have after the ball starts to spin before it's too late, but it's a second or two. You should not have any trouble getting into the U-Boot command line. If you do, then bypass the KVM switch and try again.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1291
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Early startup menu?

Postby esc » Wed Dec 20, 2017 8:53 pm

Ah, bummer. I guess I'll see if I can file a bug somewhere that is particular to u-boot, in that case. I live in a very tiny space, multiple keyboards are not an option for me, so I guess using multiple OSes on my X5000 is also not an option. :?
esc
 
Posts: 30
Joined: Sun Oct 25, 2015 7:38 pm

Re: Early startup menu?

Postby daveyw » Wed Dec 20, 2017 9:13 pm

Try just holding the spacebar down.
User avatar
daveyw
 
Posts: 162
Joined: Mon Sep 12, 2011 8:44 pm

Next

Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 1 guest