X5000 and MorphOS (V3.10)

AmigaOne X5000 platform specific issues.

X5000 and MorphOS (V3.10)

Postby AlanR » Sun May 27, 2018 4:11 pm

Hi all,

I want to try MorphOS on my X5000.
I burnt the iso on a CD (I can read it on a Windows machine).
There is the bootcyrusplus.img file. I think it's the good file for X5000.

On my X5000 I choose "Start MorphOS" at the boot menu.
The machine begins to start (finds the "good" Bootcyrus... file).
After a few second the screen freezes indicating :
"MorphOS bootloader 1.9
Find ISO9660 descriptor
Failed to find partition on device 1 (I think it's the HDD)
Booting from ISO9660
Trying to load bootCyrusplus.img from "ISO9660"
Loaded "bootcyrusplus.img" from "ISO9660", booting ..."
I hear the drive running a few seconds and after nothing.

I think it's not the good way to do.
Maybe I have to use u-boot commans and/or variables/parameters.
I don't know which.

I tried to flash the iso on a USB stick (by Rufus utility).
It seems to create a Mac OS files system (stick not recognised on a Windows computer) which can't be read by u-boot (or I don't know what to do). I have no Mac
I know that u-boot reads FAT files system.
I installed a Ubuntu Mate linux which use a small FAT partiton containing files to load (bootload "file" (at) 0x..., and linux boots.
USB commands recognises the stick as a Mac files system.

Can you tell me how I must do

Thanks a lot.
AlanR
 
Posts: 6
Joined: Sat Mar 03, 2018 9:50 am
Location: Brest - France

Re: X5000 and MorphOS (V3.10)

Postby Amigo1 » Sun May 27, 2018 8:11 pm

AlanR wrote:Hi all,



Maybe the folks at the morphos zone can help you better with this.
To me it sounds like your Graphics card is not supported.
User avatar
Amigo1
 
Posts: 176
Joined: Sun Jan 01, 2012 4:32 pm

Re: X5000 and MorphOS (V3.10)

Postby msalcedo » Mon May 28, 2018 2:45 am

per the morphos docs, the highest video card supported is the R5 230.. lots of cards in the list (maybe you have one)

Since most X5000s have Radeon 77xx cards or newer.. the morphos cd bootup just sits there

Read the 3.10 docs, switch your video card to a compatible one..
User avatar
msalcedo
Beta Tester
Beta Tester
 
Posts: 76
Joined: Fri Oct 21, 2011 12:55 am
Location: Sacramento, CA USA

Re: X5000 and MorphOS (V3.10)

Postby AlanR » Mon May 28, 2018 7:38 am

Thanks to all 2,

Yesterday I posted a question on the MorhOS mailing list.

Yes it's the graphic card whick blocks the good start.

I tried with an old HD4850, system boots correctly (a small screen in the upper left corner).

for now I'm only testing - I'll try to install it on a HDD.

Thanks a lot.
AlanR
 
Posts: 6
Joined: Sat Mar 03, 2018 9:50 am
Location: Brest - France


Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 3 guests

cron