Extremely disappointed !!!

AmigaOne X5000 platform specific issues.

Extremely disappointed !!!

Postby Steff » Sat Jul 14, 2018 2:36 pm

I have to say that after retiring at the age of 65, i would go back to the "Good Old Days of Amiga computing. However after shelling out nearly £2k on an Amiga One X5000, i am extremely disappointed with this machine. It crashes every now and again, has HDD read errors, the DVD/CD rom is unusable, the GrimReaper is a continous visitor and apart from a preaty Workbench screen, it is fundamentaly useless !!!

An expensive way to find out that in this day and age, very little software is available for this machine and the software that is available usually crashes. The facility for WB1.3 and WB3.0 emulation is so flakey, i dare'nt run it.

It is certainly NOT a Ferrari by any streatch of the imagination.

However, without you guy's trying to help out, I would have sent it back weeks ago.

Rant over.
Steff
 
Posts: 26
Joined: Sun Jun 24, 2018 4:37 pm

Re: Extremely disappointed !!!

Postby Raziel » Sat Jul 14, 2018 6:04 pm

Yes, sadly it's a catch-22 situation.

On the one hand we got new hardware, on the other hand we lack software devs, take one away and give it to the other and round you go.

The start of the XE series was very bumpy too, introducing then and now infamous hardware bugs, software glitches and whatnot.

I have an X1000 right now and while being rock stable (at times) it tends to give me PITA situations where even a seasoned Amiga hardware/software user as myself is growing even more grey hairs.

We have to live with it, i gave up waiting for anyone to "fix" anything regarding hardware.

If the X1000 should die eventually i'll be an ex-amigan
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 821
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: Extremely disappointed !!!

Postby trixie » Sun Jul 15, 2018 12:23 am

@Steff
i am extremely disappointed with this machine. It crashes every now and again, has HDD read errors, the DVD/CD rom is unusable, the GrimReaper is a continous visitor and apart from a preaty Workbench screen, it is fundamentaly useless !!!

I'm sorry to hear about your troubles but being a new X5000 user just like you, I can't say my experience is similar. My machine is very usable and stable for most of the time. Could it be a flaky PSU in your machine? That often is the cause of all sorts of problems. Faulty memory modules, and high-performing graphic cards ultimately overheating the system can be at fault as well. Also, do not forget that AmigaOS4.1 FE for the X5000 is in a beta state, which may be a factor here, too.

My biggest disappointment so far is the way the X5000 CD filesystem handles media (as it has been discussed in other threads here and elsewhere). The current behaviour where the CD/DVD drive is assigned a new device number each time you insert a medium is of course total bull and quite naturally breaks media software, which does not expect it should re-scan the drive list only because the user decided to put on a new CD.

Last but not least, do not expect classic Amiga software to just work flawlessly under OS4. The programming standards on classic Amigas were quite low, all sorts of tricks were pulled to achieve functionality, and the permissive environment of the hardware allowed programmers to get away with murder. Try to find an OS4-native solution before you put your X5000 to a particular task. Simply ask people what they use (as you have already been doing).
Smoke me a kipper, I'll be back for breakfast!

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon R5 230 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
User avatar
trixie
 
Posts: 375
Joined: Thu Jun 30, 2011 3:54 pm
Location: Czech Republic

Re: Extremely disappointed !!!

Postby Roland » Sun Jul 15, 2018 12:34 pm

Steff wrote:I have to say that after retiring at the age of 65, i would go back to the "Good Old Days of Amiga computing. However after shelling out nearly £2k on an Amiga One X5000, i am extremely disappointed with this machine. It crashes every now and again, has HDD read errors, the DVD/CD rom is unusable, the GrimReaper is a continous visitor and apart from a preaty Workbench screen, it is fundamentaly useless !!!

An expensive way to find out that in this day and age, very little software is available for this machine and the software that is available usually crashes. The facility for WB1.3 and WB3.0 emulation is so flakey, i dare'nt run it.


Steff, I fully understand your feelings, as also I have felt frustaration with all the problems I have encountered with X5000, especially during the first months. And not being myself a teenager, either, solving computer problems and learning new things is not anymore so easy as it used to be... But threre has also been many great moments, and positive feelings, especially when issues have been finally solved!

Some part of the problems are due to the fact that 4.1 FE for X5000 is still a 'prerelease'. The sad thing is that there are already fixes for several problems as revealed by the developers and testers, but they have not been published to users yet. I think we should put some pressure on Hyperion so that they would make these fixed versions available ASAP!

There are also other good sources of technical advice in addition to these Hyperion messageboards. In principle, technical support from A-Eon should become via the dealer from which you bought your machine. Did you buy your machine from AmigaKit...? If you did, you should open an account on their WWW-site, and there you can open 'tickets' describing your problems, and they should provoide you a solution. Please do not hesitate to ask, even demand help from them - it is their duty to give you support!

Another source which has been most useful is the "AmigaOne X5000 blog" (https://amigax5000.wordpress.com/). There are many very good and detailed tutorials which will save a lot of time and trouble!

* About your HDD read problems: can you give a more detailed description how they appear, and with what type of disk(s)?
I also had during first weeks several read/write problems with my HD (had even to reformat a partition because it got corrupted), but after the following operations they dissappeared:

1) Abandoned NGFS (which is still Beta) and moved to use only SFS on my HD partitions. (SFS for X5000 is included in the Enhancer software, but it is not installed correctly with the installation software - you have to activate it by adding a line for it to the "Kicklayout" file in Kickstart drawer).

2) Disabled autosaving of settings in programs like X-Dock (this was the origin of my corrupted partition!)

3) Checking regularly that the connectors of Sata cables are well seated, especially after I have installed something inside my machine, or moved the machine. Sata connctors are notorious to loosen easily, and can cause serious problems and corruption of disks...

* About classic software and UAE: There is available a newer version of UAE than that included with 4.1 FE. In that X5000 blog I mentioned you can find a tutorial how to install it. I have found it much better with old productivity tools than the older version. In my experience, some programs (e.g. PageStream) are clearly more stable with it than if run directly from 4.1. BTW, I use AmigaOS 3.5 with UAE.
- Roland -
Roland
 
Posts: 201
Joined: Tue May 02, 2017 8:23 am

Re: Extremely disappointed !!!

Postby daveyw » Sun Jul 15, 2018 11:44 pm

You're in the UK somewhere. Perhaps there is another OS4 users (or possibly an X5000 owner) nearby who could give you some help in person?

My X5000 system has been pretty good. Not too many issues around stability.
User avatar
daveyw
 
Posts: 188
Joined: Mon Sep 12, 2011 8:44 pm

Re: Extremely disappointed !!!

Postby Steff » Mon Jul 16, 2018 1:54 am

Thank you all for your suggestions and ideas. It is good to know that most people are in the same position as me (well, not so good for them either). Having worked in the "PC" dominated world since they came on stream, largely in the 90's, i have become an administrator with Microsoft accreditation for large company's etc.

As the OS4.1 FE is in its infancy (beta), i am looking to help out anyway i can for other "newbs" who happen experience the same things as i.

@DaveW
I am down in the SE of England, namely the Kent area.

@Roland.
Thanks for the link. I have solved the read errors on HD0. After i initially formatted the HD, i used a standard (default FFS) format. I since found out that i should have used the SFS/02. I also found (while testing) that if i formatted my USB stick the same way, i can now backup the entire HD0 to it and also making it bootable!! (learning curve #32). Thanks also for the AmigaOS 3.5 with UAE suggestion. I will give that a try tomorrow.

@Trixie
I concur with the X5000 CD filesystem. It is sending me crazy. But as the OS is beta, i can only persevere with it for now. Someone suggested "Frying Pan" which i have now downloaded and installed. I will play around with that at some point and see if it is better than AmiDVD.

@Raziel.
Sadly it's a catch-22 situation, is correct.

However, i am someone that does like a challenge and now that i have retired, i have lot's of time to figure them out.

Thanks again All !!
Steff
 
Posts: 26
Joined: Sun Jun 24, 2018 4:37 pm

Re: Extremely disappointed !!!

Postby nbache » Mon Jul 16, 2018 11:38 am

Steff wrote:I have solved the read errors on HD0. After i initially formatted the HD, i used a standard (default FFS) format. I since found out that i should have used the SFS/02.
Whlie FFS2 is old and slow, it should not give read errors.

But when you say "default FFS", I become a bit suspicious. You did set it to DOS\07, i.e. the FFS variant with long file names, right? It is mandatory for installing OS4.

Anyway, if SFS works for you, then no problem. Once you get hold of an updated NGFS (whenever that may be released ...), you can always start using that for new partitions.

Oh, and whatever you do, keep making backups. No filesystem is perfect, and even if it were, there's also the possibility of physical disk errors etc.- plus there's always the human factor ;-). Of course, given your background, you should know that already.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1278
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark


Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 4 guests