ubuntu MATE 16.04.1 LTS Live USB

AmigaOne X5000 platform specific issues related to Linux only.

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 10:31 pm

Is
smbclient -L servername
working ?
Spectre660
 
Posts: 1462
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Tue Dec 05, 2017 10:53 pm

Yes, smbclient works fine.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 11:05 pm

Can you connect using the connect to server option in the "Places "Menu ?
Using Type "Windows share"
This works for me .
not sure what I am doing wrong with the cli commands though.
Spectre660
 
Posts: 1462
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Tue Dec 05, 2017 11:15 pm

Yes, that works here too.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 11:36 pm

So the Samba and cifs protocol should be working with the kernels.
I am still not sure what is going wrong with the cli commands .

softwarefailure wrote:Yes, that works here too.
Spectre660
 
Posts: 1462
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 11:45 pm

I am looking at the X1000 kernel .config .
It does not have support for some of the newer protocols (SMB311).
This could be what is causing the issue.


CONFIG_CIFS=y
# CONFIG_CIFS_STATS is not set
CONFIG_CIFS_WEAK_PW_HASH=y
# CONFIG_CIFS_XATTR is not set
CONFIG_CIFS_DEBUG=y
# CONFIG_CIFS_DEBUG2 is not set
# CONFIG_CIFS_DEBUG_DUMP_KEYS is not set
# CONFIG_CIFS_SMB311 is not set

My X5000 config does .

CONFIG_CIFS=y
# CONFIG_CIFS_STATS is not set
CONFIG_CIFS_WEAK_PW_HASH=y
CONFIG_CIFS_UPCALL=y
CONFIG_CIFS_XATTR=y
CONFIG_CIFS_POSIX=y
CONFIG_CIFS_ACL=y
CONFIG_CIFS_DEBUG=y
# CONFIG_CIFS_DEBUG2 is not set
# CONFIG_CIFS_DEBUG_DUMP_KEYS is not set
CONFIG_CIFS_DFS_UPCALL=y
CONFIG_CIFS_SMB311=y
CONFIG_CIFS_FSCACHE=y
Spectre660
 
Posts: 1462
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby xeno74 » Wed Dec 06, 2017 2:17 pm

softwarefailure wrote:On the X1000 this is working fine.


Did you mean you can mount the SMB shares from your X1000 with the X5000 but not the other way around?

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3772
Joined: Fri Mar 23, 2012 8:58 am

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Wed Dec 06, 2017 6:13 pm

xeno74 wrote:Did you mean you can mount the SMB shares from your X1000 with the X5000 but not the other way around?


No, I'm trying to mount SMB shares from a QNAP NAS device. It works fine on the X1000 with A-EON's Ubuntu 12.04 for the X1000 but it doesn't work with Ubuntu MATE 16.04 on the X5000.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Thu Dec 07, 2017 3:47 pm

So is there anything else I can try to get this working? It's quite important for me.

As I said earlier, I can mount the shares from the "Places" menu but AFAICS, this won't allow me to access them from bash. Their location is listed as smb://mynas.local/stuff/ but of course that's nothing that bash can handle.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Skateman » Thu Dec 07, 2017 9:18 pm

Hi, have you tried replacing the name for the ip adress.... i guess you havve but you never know...

smb://IPadress/
User avatar
Skateman
 
Posts: 152
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

PreviousNext

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests