ubuntu MATE 16.04.1 LTS Live USB

AmigaOne X5000 platform specific issues related to Linux only.

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 3:45 pm

This is the on board ethernet MAC address. This will not affect you currently .
Does the ethernet card work from AmigaOS 4.1 (if you have AmigaOS 4.1 installed) ?



softwarefailure wrote:In System Info it says NULL for "MAC Address" and "MAC Address 2" so I guess there's something wrong with the network card? What should I do now? Contact my dealer about it?
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 3:49 pm

This is what I get when I run the installer.
This is a PCI 8139 ethernet card in the last PCI slot of my X5000 .
See the Right side of image # 1 for the System Information info
8139 Network Controller
Attachments
IMG_0545.JPG
IMG_0544.JPG
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Tue Dec 05, 2017 4:06 pm

Ok, on my X5000 the network card isn't even listed in System Info. So there definitely seems to be something wrong with the card. I guess I have to contact my dealer about this then or is there anything else I can try? I only have

0 Processor
1 Display controller
1 Multimedia device
2 Processor
6 Multimedia device

in the list of PCI devices.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 4:11 pm

The Ethernet card could have become loose during shipping.
You could try to re seat it .

softwarefailure wrote:Ok, on my X5000 the network card isn't even listed in System Info. So there definitely seems to be something wrong with the card. I guess I have to contact my dealer about this then or is there anything else I can try? I only have

0 Processor
1 Display controller
1 Multimedia device
2 Processor
6 Multimedia device

in the list of PCI devices.
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Tue Dec 05, 2017 9:50 pm

Alright, reseating the network really did solve the problem. Now I could install Ubuntu Mate on the X5000 just fine. However, when I try to mount my SMB shared using

[code]
mount -t cifs -o username=$user,password=$pwd,file_mode=0777,dir_mode=0777,uid=1000 //192.168.0.123/stuff /mnt/stuff
[code]

I get the following error: Mount failed: host is down. I can ping 192.168.0.123 just fine, though, so the host isn't really down. Does the kernel support cifs mounts on the X5000? On the X1000 this is working fine.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 10:01 pm

You may need to install samba anf cifs stuff first.

sudo apt-get install samba
sudo apt-get install cifs-utils

My X5000 kernels should support cifs.

CONFIG_CIFS=y
# CONFIG_CIFS_STATS is not set
CONFIG_CIFS_WEAK_PW_HASH=y
CONFIG_CIFS_UPCALL=y
CONFIG_CIFS_XATTR=y
CONFIG_CIFS_POSIX=y
CONFIG_CIFS_ACL=y
CONFIG_CIFS_DEBUG=y
# CONFIG_CIFS_DEBUG2 is not set
# CONFIG_CIFS_DEBUG_DUMP_KEYS is not set
CONFIG_CIFS_DFS_UPCALL=y
CONFIG_CIFS_SMB311=y
CONFIG_CIFS_FSCACHE=y


softwarefailure wrote:Alright, reseating the network really did solve the problem. Now I could install Ubuntu Mate on the X5000 just fine. However, when I try to mount my SMB shared using

[code]
mount -t cifs -o username=$user,password=$pwd,file_mode=0777,dir_mode=0777,uid=1000 //192.168.0.123/stuff /mnt/stuff
[code]

I get the following error: Mount failed: host is down. I can ping 192.168.0.123 just fine, though, so the host isn't really down. Does the kernel support cifs mounts on the X5000? On the X1000 this is working fine.
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Tue Dec 05, 2017 10:09 pm

I've installed Samba, but it still says "host not found"?!
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 10:13 pm

What about the cifs-utils ?

softwarefailure wrote:I've installed Samba, but it still says "host not found"?!
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby softwarefailure » Tue Dec 05, 2017 10:21 pm

Still mount error 112: host is down.
softwarefailure
 
Posts: 91
Joined: Fri Feb 14, 2014 11:29 pm

Re: ubuntu MATE 16.04.1 LTS Live USB

Postby Spectre660 » Tue Dec 05, 2017 10:27 pm

I will have to verify the kernel cifs support.
Samba works ok for me but I have never used cifs.


softwarefailure wrote:Still mount error 112: host is down.
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

PreviousNext

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests

cron