Kernel 4.9

AmigaOne X5000 platform specific issues related to Linux only.

Re: Kernel 4.9

Postby xeno74 » Fri Dec 16, 2016 10:37 pm

Radek wrote:Hi Christian,

Thank for you help, i'll try different partition for linux and AOS as soon as i get around this issue:

GParted 0.25.0 --enable-libparted-dmraid --enable-online-resize

Libparted 3.2

Create Primary Partition #1 (ext4, 3.26 GiB) on /dev/sdb 00:00:00 ( ERROR )

create empty partition 00:00:00 ( ERROR )
libparted messages ( INFO )

Unable to satisfy all constraints on the partition.
========================================

Create Primary Partition #2 (ext4, 229.57 GiB) on /dev/sdb
========================================


That's the error message i mentioned earlier. I can see there is no much info and probably
will not be enough, so if there is any other, more verbose, way of getting more detailed error log,
let me know.


PS. Ok, i think i know where is the problem with parted and my mmc card, not solution though ; ).
In GParted i selected HD intended as a linux installation, in my case /dev/sdb
but Terminal says that i execute operations on /dev/mmcblk0: - my mmc card!!!
Why this is happening and how to change that?

PS.2 I.ve tried to take a screenshot with Accessories/Take Screenshot app, but it says:
Error loading UI definition file... bla bla bla. I bet i need to install linux first before i can use it?
Vicious circle :D

Thanks,
Radek.


Hi Radek,

I think /dev/sdb2 is your mmc card because you have only two SATA connectors. The first one is for the HD and the second one is for the DVD drive. That means you have to create partitions on /dev/sda.

My suggestion:

/dev/sda1 Linux boot partition with kernels, initrds, and dtb files with fat32 formated.
/dev/sda2 OS4.1
/dev/sda3 Linux root partition

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.9

Postby xeno74 » Sat Dec 17, 2016 12:21 am

Radek,

Did you use the alternative installer?

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.9

Postby daz » Sat Dec 17, 2016 12:24 am

Radek wrote:Hi Christian,

Thank for you help, i'll try different partition for linux and AOS as soon as i get around this issue:

GParted 0.25.0 --enable-libparted-dmraid --enable-online-resize

Libparted 3.2

Create Primary Partition #1 (ext4, 3.26 GiB) on /dev/sdb 00:00:00 ( ERROR )

create empty partition 00:00:00 ( ERROR )
libparted messages ( INFO )

Unable to satisfy all constraints on the partition.
========================================

Create Primary Partition #2 (ext4, 229.57 GiB) on /dev/sdb
========================================


That's the error message i mentioned earlier. I can see there is no much info and probably
will not be enough, so if there is any other, more verbose, way of getting more detailed error log,
let me know.


This can happen when you've selected the wrong Align for the partition, not sure how you set that from the command line, it's quite easy from the gui.

Only one of the options works (A bug on PowerPC I think) - None, I think it defaults to Megabyte.

Try again with this value corrected.

PS. Ok, i think i know where is the problem with parted and my mmc card, not solution though ; ).
In GParted i selected HD intended as a linux installation, in my case /dev/sdb
but Terminal says that i execute operations on /dev/mmcblk0: - my mmc card!!!
Why this is happening and how to change that?


Are you sure your HDD is sdb? On my system it is Always sda. The mmcblk0 driver doesn't affect this.

Or do you have 2 HDD's attached?

Regards
Darren
daz
Beta Tester
Beta Tester
 
Posts: 299
Joined: Tue Dec 21, 2010 8:32 pm

Re: Kernel 4.9

Postby JohnFante » Sat Dec 17, 2016 2:06 pm

xeno74 wrote:Hi All,

Sinan released the RC8 yesterday.

Many thanks to Sinan! :-)

Download: Cyrus-4.9rc8.tar.gz

Please test the RC8.

Thanks,
Christian


First of all I am a bit unsure wether I installed the new kernel it correctly. I load the kernel from an USB stick since my linux partition is on a HD connected to one of the ports on my four port sata card. Therefore I just extracted the kernel files and copied uimage to the USB and renamed it uImage-cyrus as was the case wit the RC5 kernel.

When I try to boot the RC7 and RC8 kernels they crash for me. Turns off the screen after It loads the kernel and then hang. No output or anything. It looks like it is the Xorg package that crashes. At least that is what it says when I booted the system again with the RC5 kernel after trying to use the RC8.

I used the alternative install script to install. That means that it starts up in the ubuntu mate-live user. I have added a user with my name. How do I get the system to boot into that user automaticly?

And btw. there is no 3d acceleration on my Radeon R270X but that maybe the kernel?
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 138
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: Kernel 4.9

Postby JohnFante » Sat Dec 17, 2016 6:34 pm

xeno74 wrote:Hi All,

Luigi released the RC6 of kernel 4.9 with the talos patch included two weeks ago. :-)

Download: kernel_49rc6_talos_patch.zip

Cheers,
Christian


Tried Luigis kernel but the machine just freezes after loading the kernel.

https://www.dropbox.com/s/zwjh7s2ek2aul ... s.jpg?dl=0
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 138
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: Kernel 4.9

Postby xeno74 » Sun Dec 18, 2016 7:14 am

The final version of kernel 4.9 is available for the AmigaOne X5000.

Download: Cyrus-4.9.tar.gz

Many thanks to Sinan for creating this kernel.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.9

Postby JohnFante » Sun Dec 18, 2016 11:26 am

xeno74 wrote:The final version of kernel 4.9 is available for the AmigaOne X5000.

Download: Cyrus-4.9.tar.gz

Many thanks to Sinan for creating this kernel.


Strange! I can not get this kernel to boot either. Turns off the screen after loading the kernel as RC7 and RC8. :(

I am using this boot command: https://www.dropbox.com/s/o2wpngnvg0c6oog/49.jpg?dl=0

Any suggestions? After I installed the system I updated all the software (around 350MB) but that is it.

Btw: I am running a Radeon R9 270X can that be the culprit?

And yes! Thanks to Sinan for creating the kernel - even if it does not work for me.
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 138
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: Kernel 4.9

Postby tlosmx » Sun Dec 18, 2016 12:12 pm

hi need to know what distro are you using?
ciao
luigi
AmigaOne Xe 933 mhz Radeon 9000pro Samsung 840 SSD
Pegasos2 1266mhz Radeon 9800pro Verbatib Sata3 SSD
Sam 460ex Lite 2gb Ram , Radeon 6670,Toshiba 500gb Sata/HDD
Amiga Cd32 / Amiga 600 / Amiga 500 / Amiga CDtv/ Amiga 4000 / Amiga 1200 /Amiga 2000 and many many many z3 Boards
tlosmx
Beta Tester
Beta Tester
 
Posts: 195
Joined: Sat Feb 09, 2013 10:15 am

Re: Kernel 4.9

Postby JohnFante » Sun Dec 18, 2016 12:20 pm

tlosmx wrote:hi need to know what distro are you using?
ciao
luigi


I am using ubuntu MATE 16.04.1 LTS.

viewtopic.php?f=58&t=3577

Installed via the alternative installer on the desktop when I load the live USB. The provided RC5 kernel works but the rest fail for me.
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 138
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: Kernel 4.9

Postby seventhwonder » Sun Dec 18, 2016 1:34 pm

JohnFante wrote:
xeno74 wrote:The final version of kernel 4.9 is available for the AmigaOne X5000.

Download: Cyrus-4.9.tar.gz

Many thanks to Sinan for creating this kernel.


Strange! I can not get this kernel to boot either. Turns off the screen after loading the kernel as RC7 and RC8. :(

I am using this boot command: https://www.dropbox.com/s/o2wpngnvg0c6oog/49.jpg?dl=0

Any suggestions? After I installed the system I updated all the software (around 350MB) but that is it.

Btw: I am running a Radeon R9 270X can that be the culprit?

And yes! Thanks to Sinan for creating the kernel - even if it does not work for me.



Can you tell me the output of following

$ lspci -nn | grep VGA

Probably our kernels do not have your gfx card's firmware.
AmigaOS4 Beta-Tester
**AmigaOne X5000 + 8GB RAM + Asus Radeon R7 265 GDDR5**
**Tabor A1222 + 2GB RAM + Asus Radeon HD R7 265 GDDR5 **
**Sam460 + 2GB RAM + Radeon HD 7750 GDDR5 **
seventhwonder
Beta Tester
Beta Tester
 
Posts: 200
Joined: Sat Jun 18, 2011 8:08 am

PreviousNext

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests