Spectre660's Linux downloads for the X5000

AmigaOne X5000 platform specific issues related to Linux only.

Re: Spectre660's Linux downloads for the X5000

Postby Spectre660 » Wed Dec 13, 2017 2:38 pm

Glad to be able to help.

Note that when you install the pciex1 SATA controller the first hard drive connected to it will be /dev/sda so you will have to remember to change the U-Boot variable to point to the correct Linux partition.

Skateman wrote:Just wanted to say thanks for the great instructions regarding the Linux installation on the X5000.

Having the X5000 for just a few days, and with no knowledge of U-Boot, i managed to get Ubuntu up and running.
So Spectre660, and everyone else who contributes to getting Linux up and running on the AmigaOne X series... great work!!

For now i detached the X5000 Optical drive, and attached a 1TB 7200rpm disk and installed Ubuntu on this.
Next steps planned:
re-attach cd Optical drive
insert a Pci-E X1 Sata controller and attach a SSD drive
Install Ubuntu again.
Getting rid of the permanent USB key and move the kernel to the X5000 SD card... (the hard part)
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Spectre660's Linux downloads for the X5000

Postby Skateman » Thu Dec 14, 2017 8:46 am

And the second step has been completed.... (thanks again for your instructions Spectre660)

The X5000 has the kernel files now on the U-Boot SDcard and it booting from this. I even managed to make a copy of the original SD card and all is running from a copy right now.
The original U-Boot SD is safe in case of emergency!
User avatar
Skateman
 
Posts: 176
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: Spectre660's Linux downloads for the X5000

Postby Spectre660 » Thu Dec 14, 2017 5:55 pm

Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Spectre660's Linux downloads for the X5000

Postby caseycullen » Thu Apr 19, 2018 11:46 pm

Spectre660 wrote:Debian 9/Sid ppc64 Installer
http://dl.dropboxusercontent.com/s/1qxe ... net-4?dl=0
Need Debian Sid ppc64 DVD.iso can be copied to USB thumb drive with dd instead of burning DVD.
https://cdimage.debian.org/cdimage/port ... INST-1.iso


I'm trying to get Debian Buster/Sid PPC64 running on my X5000. I'm able to copy the DVD iso onto a thumb drive along with a FAT32 partition for the kernel and uRamdisk_debian_9-ppc64-net-4. This loading into the Debian installer, I choose English, etc. until it gets to the Partition Disks step. Then I get the error "Failed to load installer component Loading libc6-udeb failed for unknown reasons. Aborting."
Is this a known issue or do you know of a solution? Any ideas?
Thanks!
---Casey
caseycullen
 
Posts: 115
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Spectre660's Linux downloads for the X5000

Postby Spectre660 » Fri Apr 20, 2018 12:21 am

@caseycullen

There seems to be an issue with the current iso. I also get the same error with it.
I am uploading an old .iso from 27Aug2017 that is working and will post the link when the upload is finished .

caseycullen wrote:
Spectre660 wrote:Debian 9/Sid ppc64 Installer
http://dl.dropboxusercontent.com/s/1qxe ... net-4?dl=0
Need Debian Sid ppc64 DVD.iso can be copied to USB thumb drive with dd instead of burning DVD.
https://cdimage.debian.org/cdimage/port ... INST-1.iso


I'm trying to get Debian Buster/Sid PPC64 running on my X5000. I'm able to copy the DVD iso onto a thumb drive along with a FAT32 partition for the kernel and uRamdisk_debian_9-ppc64-net-4. This loading into the Debian installer, I choose English, etc. until it gets to the Partition Disks step. Then I get the error "Failed to load installer component Loading libc6-udeb failed for unknown reasons. Aborting."
Is this a known issue or do you know of a solution? Any ideas?
Thanks!
---Casey
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Spectre660's Linux downloads for the X5000

Postby caseycullen » Fri Apr 20, 2018 3:08 am

Spectre660 wrote:@caseycullen
There seems to be an issue with the current iso. I also get the same error with it.
I am uploading an old .iso from 27Aug2017 that is working and will post the link when the upload is finished .

Awesome, thanks :)
---Casey
caseycullen
 
Posts: 115
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Spectre660's Linux downloads for the X5000

Postby Spectre660 » Fri Apr 20, 2018 4:17 am

@caseycullen

Here you go.
If it tries to install grub and fails then just navigate to the menu option to continue without a boot loader and it should complete the installation ok .

http://dl.dropboxusercontent.com/s/9p35 ... 7.iso?dl=0
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Spectre660's Linux downloads for the X5000

Postby Spectre660 » Fri Apr 20, 2018 12:14 pm

@caseycullen

The culprit was my ramdisk.
Have updated and uploaded updated version 5.
Link in the first post in this thread as usual.
So the new ramdisk works with the latest iso .
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Spectre660's Linux downloads for the X5000

Postby caseycullen » Fri Apr 20, 2018 7:14 pm

Spectre660 wrote:@caseycullen

Here you go.
If it tries to install grub and fails then just navigate to the menu option to continue without a boot loader and it should complete the installation ok .

http://dl.dropboxusercontent.com/s/9p35 ... 7.iso?dl=0


Using this image I was able to install the base system and boot to it. However, during the installation I was unable to connect to a Debian mirror to install more than just the base system. The error was "The installer failed to access the mirror.... Downloading a file failed". I logged into a shell and pinged google to ensure my connection was working, which it was. After the base system was installed, I added the Debian Sid repos to sources.list (I assume they weren't there due to the mirror issue), ran "apt-get update", apt-get downloaded the repo index, but when I tried to "apt-get install" any package (I tried several) the package could not be found. I also tried "--allow-unauthorized" to make sure that wasn't the problem. I wonder if this is an issue on my side or the repo side, considering I was having xorg dependency issues using Christian's preinstalled image earlier as well.

Spectre660 wrote:@caseycullen

The culprit was my ramdisk.
Have updated and uploaded updated version 5.
Link in the first post in this thread as usual.
So the new ramdisk works with the latest iso .

I'll try the new ramdisk and iso later tonight. Thanks for your help!

---Casey
caseycullen
 
Posts: 115
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Spectre660's Linux downloads for the X5000

Postby Spectre660 » Fri Apr 20, 2018 7:53 pm

@caseycullen

I will try to do a fresh install as a test also .
I was just able to update my current installation .

As far as I remember I never had to edit the repositories.
Spectre660
 
Posts: 1470
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

PreviousNext

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 3 guests

cron