AmigaOne X5000 - FreeBSD Only

AmigaOne X5000 platform specific issues related to Linux only.

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Mon Oct 22, 2018 9:15 pm

Could the missing a /chosen node be the issue with the ¨not¨ working X5000 DPAA Ethernet adapter within Ubuntu PPC?

Would be great if just a new dtb would solve the issue :-)
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 223
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: AmigaOne X5000 - FreeBSD Only

Postby chmeee » Tue Oct 23, 2018 4:04 am

Skateman wrote:Could the missing a /chosen node be the issue with the ¨not¨ working X5000 DPAA Ethernet adapter within Ubuntu PPC?

Would be great if just a new dtb would solve the issue :-)


I highly doubt that, since /chosen is only really used for passing bootargs and stdin/stdout (among a few others). Unless bootargs control the ethernet, I doubt you'd see any benefit, if Ubuntu already boots, but ethernet is nonfunctional.

Anyway, I committed r339632 to FreeBSD, which is the last bit on the FreeBSD side to make that dtb work.
chmeee
 
Posts: 5
Joined: Wed Mar 07, 2018 10:04 pm

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Mon Nov 05, 2018 10:33 pm

@chmeee

Could you give me the output of your command dmesg |grep eth

skateman@X5000LNX:~$ dmesg |grep eth
[ 5.923682] fsl_dpaa_mac ffe4e6000.ethernet: FMan dTSEC version: 0x08240101
[ 5.924476] fsl_dpaa_mac ffe4e6000.ethernet: FMan MAC address: 00:04:a3:6b:41:7c
[ 5.924811] fsl_dpaa_mac ffe4e8000.ethernet: FMan dTSEC version: 0x08240101
[ 5.925202] fsl_dpaa_mac ffe4e8000.ethernet: FMan MAC address: 00:1e:c0:f8:31:b5
[ 5.925455] fsl_dpaa_mac ffe4e0000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@e0000) failed
[ 5.925665] fsl_dpaa_mac: probe of ffe4e0000.ethernet failed with error -22
[ 5.925831] fsl_dpaa_mac ffe4e2000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@e2000) failed
[ 5.926035] fsl_dpaa_mac: probe of ffe4e2000.ethernet failed with error -22
[ 5.926205] fsl_dpaa_mac ffe4e4000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@e4000) failed
[ 5.926431] fsl_dpaa_mac: probe of ffe4e4000.ethernet failed with error -22
[ 5.931246] fsl_dpaa_mac ffe4f0000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@f0000) failed
[ 5.936167] fsl_dpaa_mac: probe of ffe4f0000.ethernet failed with error -22
[ 5.943283] fsl_dpaa_mac ffe4e6000.ethernet eth0: Probed interface eth0
[ 5.950269] fsl_dpaa_mac ffe4e8000.ethernet eth1: Probed interface eth1
[ 12.659922] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.660691] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.695396] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 12.696141] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 93.466321] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 344.816821] device eth0 entered promiscuous mode
[ 370.958485] device eth0 left promiscuous mode
[ 442.274641] asix 1-1.3.4.3:1.0 eth2: register 'asix' at usb-fsl-ehci.0-1.3.4.3, ASIX AX88772B USB 2.0 Ethernet, 00:0e:c6:f4:d3:c7
[ 442.281401] asix 1-1.3.4.3:1.0 enx000ec6f4d3c7: renamed from eth2
[ 512.324022] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 525.058597] device eth0 entered promiscuous mode
[ 559.304853] device eth0 left promiscuous mode

Thanks.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 223
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Previous

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 7 guests