(X)(L)ubuntu (MATE) 16.04 LTS

AmigaOne X1000 platform specific issues related to Linux only.

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Tue May 10, 2016 5:43 am

Amigo1 wrote:Hi Christian,

today I tested the unofficial Mesa, but I still get a uniform colored screen. (I restarted Ubuntu) See screen shots.
I could however play one .mov file. So I'm not sure the issue is with the video card (driver) anymore.

I sudo apt-get purge --auto-removed and reinstalled the ubuntu-restricted-extras to no avail.. What could it be?


Hi Amigo1,

Thank you for testing. If I understand it correctly, you was able to play a .mov file with the unofficial Mesa 1.0.0.4 without any problems.
That's fantastic! Good to know. :-)

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3174
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby Amigo1 » Tue May 10, 2016 2:32 pm

xeno74 wrote:
Amigo1 wrote:Hi Christian,

today I tested the unofficial Mesa, but I still get a uniform colored screen. (I restarted Ubuntu) See screen shots.
I could however play one .mov file. So I'm not sure the issue is with the video card (driver) anymore.

I sudo apt-get purge --auto-removed and reinstalled the ubuntu-restricted-extras to no avail.. What could it be?


Hi Amigo1,

Thank you for testing. If I understand it correctly, you was able to play a .mov file with the unofficial Mesa 1.0.0.4 without any problems.
That's fantastic! Good to know. :-)

Cheers,

Christian


Actually not, I did not express myself correctly, my bad. the .mov file was with the official mesa

edit: btw, can you play video files?
Also, I tried to play HD video on YouTube, it's a slide show. Even with low resolution videos the playback is too slow. Is it the same on your A1 X1000?
User avatar
Amigo1
 
Posts: 158
Joined: Sun Jan 01, 2012 4:32 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Tue May 10, 2016 9:41 pm

Amigo1 wrote:Actually not, I did not express myself correctly, my bad. the .mov file was with the official mesa

edit: btw, can you play video files?
Also, I tried to play HD video on YouTube, it's a slide show. Even with low resolution videos the playback is too slow. Is it the same on your A1 X1000?


Hi Amigo1,

No, it isn't. I can play HD videos on YouTube with ViewTube. Have you already tried ViewTube?

Image

YouTube videos in HD with ViewTube

Installation instructions for ubuntu MATE 16.04 PowerPC

  1. Install VLC and the VLC browser plugin with the following command:
    Code: Select all
    sudo apt-get install browser-plugin-vlc
  2. Start Firefox and install the add-on Greasemonkey
  3. Restart Firefox
  4. After that, add the ViewTube script to Greasemonkey

Image

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3174
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Tue May 10, 2016 11:01 pm

ubuntu MATE 16.04 LTS PowerPC with kernel 4.6-rc7. :-)

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3174
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby kilaueabart » Wed May 11, 2016 11:08 pm

xeno74 wrote:Hi All,

Today, Ubuntu 16.04 LTS has been released.

On May 3rd I copied the release image of ubuntu MATE 16.04 LTS to a 1TB hard disk which GParted told me was completely unallocated.
I confess I do not remember what I did to the disk to put it in 100% unallocated condition. Possibly a source of problems?

For a few days I couldn't log in, but that mysteriously changed, and I have a mostly working MATE with all kinds of interesting possibilities,
but also a bunch of problems, two of which are in a sense sort of crippling:

1. I cannot open other devices, such as flash drives or the CF CARD. At first MATE would complain that "The file is of unknown type."
Since last night that has changed to something like "You do not have permission." Not being able to easily move files from one device to
another is very limiting, although I think I can do so from a terminal.

2. I normally use a 1920x1280 screen as my monitor prefers. Judging from the show of four desktops in the lower right, MATE is giving me
virtual desktops twice that wide. Yesterday I saw that some windows I had tried to open had appeared in the inaccessible right hand side
of that super-wide desktop. By then I had lost the mouse arrow, perhaps lost in that part of the screen? Had to shut down by hand.

I spent much time yesterday reviewing the (then) almost 170 posts in this thread, taking note of suggestions made for various problems.
One of them was about modprobe failure. "Try sudo depmod -va ... sudo modprobe kernel-module." Out of curiousity I tried those, got told
there were no modules available.

I added the ones for kernel 4.21 to my CF CARD and copied to /lib/modules/. When I looked into /lib/modules/ I was startled to find six files. In addition to what I had just added there was a 4.4.3-sam440ep, a 4.4.4 ...Nemo, a 4.4.4-cyrus-jm, a 4.4.6-sam460ex.jm, and a 4.4.6-tabor-jm. How come?

I also found out that my 12.04 install had no 4.21 modules, but it always seemed to work fine. I copied them to 12.04's /lib/modules/ as well,
but I hope they don't mess anything up.

Maybe the big question of the day is, if I upgrade to 16.10 without solving those problems, will they get solved automatically, or is it likely to
make matters even worse?
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Thu May 12, 2016 9:23 am

kilaueabart wrote:Maybe the big question of the day is, if I upgrade to 16.10 without solving those problems, will they get solved automatically, or is it likely to
make matters even worse?


In my point of view it is not a good idea to upgrade to 16.10 without solving those problems.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3174
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby papaoskar » Thu May 12, 2016 6:42 pm

papaoskar wrote:I have a 64 GB stick also. I will try that one.

Hi Christian,
I was successful with a 16GB stick. It boots nicely, however I could persuade the stick to accept german language and keyboard. But no german for the system to apply system wide.
I have done the copy process according to your advice with the commands: cp -a * /mnt . The copy command stops when it comes to /proc - directory. Too many errors and then it stops.
How about producing an img file from the stick and then dumping that img to /dev/sdb8 ? Perhaps I have to go to ubuntu 12.4 and do the copying from there?
papaoskar
 
Posts: 80
Joined: Tue Jul 01, 2014 2:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby kilaueabart » Fri May 13, 2016 2:59 am

xeno74 wrote:In my point of view it is not a good idea to upgrade to 16.10 without solving those problems.
Thanks. That was my guess, but I secretly hoped maybe those autoremove and cleanup commands might clear the problem areas. It's starting to look like I may have to be satisfied with 12.04, but I really like MATE.

Another question, if I may. My install has these probably quite normal initial partitions:
/dev/sdb1 FAT 16 AMIGAONE 100.00 MiB, 32.15 MiB Used, 67.85 Unused
/dev/sdb2 ext 4 Ubuntu_16.04 7.02 GiB, 4.87 GiB Used, 2.15 GiB Unused
/dev/sdb3 ext2 Sam4xx 100.00 MiB, 13.59 MiB Used, 86.41 MiB Unused

/dev/sdb2 seems way too small. Considering it's on a 1TB hard drive, how large would you advise I make it?
Are /dev/sdb1 and /dev/sdb3 of any use? Should I move /dev/sdb3 before I enlarge /dev/sdb2, or just delete it?
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby jdupuis » Fri May 13, 2016 5:26 am

kilaueabart wrote:
xeno74 wrote:In my point of view it is not a good idea to upgrade to 16.10 without solving those problems.
Thanks. That was my guess, but I secretly hoped maybe those autoremove and cleanup commands might clear the problem areas. It's starting to look like I may have to be satisfied with 12.04, but I really like MATE.

Another question, if I may. My install has these probably quite normal initial partitions:
/dev/sdb1 FAT 16 AMIGAONE 100.00 MiB, 32.15 MiB Used, 67.85 Unused
/dev/sdb2 ext 4 Ubuntu_16.04 7.02 GiB, 4.87 GiB Used, 2.15 GiB Unused
/dev/sdb3 ext2 Sam4xx 100.00 MiB, 13.59 MiB Used, 86.41 MiB Unused

/dev/sdb2 seems way too small. Considering it's on a 1TB hard drive, how large would you advise I make it?
Are /dev/sdb1 and /dev/sdb3 of any use? Should I move /dev/sdb3 before I enlarge /dev/sdb2, or just delete it?


Hi Bart,

Christian passed on to me in another post that the Sam4xx Partition can be deleted and expand sdb2. After deleting the Sam partition, I created an Extended Swap Partition at the end and expanded sdb2 to fill the unallocated space left over. Your choice. To answer your question, delete the Sam partition first, then expand your sdb2 to the size that fits your needs.

Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby kilaueabart » Fri May 13, 2016 5:41 am

Thanks, John. I'll do something like that, but maybe not devote a whole terabyte to MATE. I don't know if the one I'm working on is ever going to be truly usable anyway. I was going to bring the following up somewhere. How about here?

I found the following when looking for solutions to my desktop size problem.
http://askubuntu.com/questions/176801/c ... on-in-mate
In a reply to someone with a similar problem I found this:
Follow these steps:
cd /etc/xdg/autostart/
Always backup your files, just in case:
sudo cp gnome-settings-daemon.desktop gnome-settings-daemon.desktop.bak

Later some changes to that file are specified. However, Terminal tells me I have no such file. I do have mate-settings-daemon.desktop and made the changes suggested for that, to no avail. My desktop screen is still about 3840x1080, left-half only showing on my 1920x1080 monitor screen.

I am going to try to create a gnome-settings-daemon.desktop with the follow replacement suggestions. If you are reading this note, that means it didn't work.
Then replace the text with the following:
[Desktop Entry]
Type=Application
Name=MATE Settings Daemon
Exec=/usr/bin/mate-settings-daemon
OnlyShowIn=MATE;
NoDisplay=true
X-GNOME-Autostart-Phase=Initialization
X-GNOME-Autostart-Notify=true
X-GNOME-AutoRestart=true
X-Ubuntu-Gettext-Domain=gnome-settings-daemon

Actually, I don't see why it should have worked. I don't see any reference to size. Maybe I should google "desktop size" instead of "screen size." (And next, "how to switch '"' and '@' to the proper keys." Sheesh!)
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 5 guests