Cannot install 4.1 FE Update 1 on A1XE

A forum for AmigaOne XE and MicroA1-C specific issues.

Cannot install 4.1 FE Update 1 on A1XE

Postby daveyw » Sun Jan 01, 2017 2:50 am

Hi,

The install script is failing when I try and run it.

After selecting SYS:, I get a DOS window with "Cannot open "SYS:" for output - COPY: object is in use".

Then, after clicking "Next" three time, I get "Error while copying Python, object in use".
User avatar
daveyw
 
Posts: 144
Joined: Mon Sep 12, 2011 8:44 pm

Re: Cannot install 4.1 FE Update 1 on A1XE

Postby javierdlr » Sun Jan 01, 2017 11:29 pm

Using AmiUpdate or downloading from hyperion site?

Try to (re)download again (AmiUpdate or HP site) nad without any other program open (or without WBStartup started) try to install again Update1.
User avatar
javierdlr
Beta Tester
Beta Tester
 
Posts: 367
Joined: Sun Jun 19, 2011 11:13 pm
Location: Donostia (GUIPUZCOA) - Spain

Re: Cannot install 4.1 FE Update 1 on A1XE

Postby daveyw » Mon Jan 02, 2017 12:52 am

Both, although they both fail at different places.

What I wrote above is where it fails when installing from the distro downloaded from Hyperion.

If I run AmiUpdate, it fails on _socket.so
User avatar
daveyw
 
Posts: 144
Joined: Mon Sep 12, 2011 8:44 pm

Re: Cannot install 4.1 FE Update 1 on A1XE

Postby daveyw » Mon Jan 02, 2017 1:22 am

Got it!

I had to boot from the 4.1FE CD, and then run the installer, pointing it not to SYS: but my boot HD partition (DH0:).

I think the Python install script was possibly trying to update components on the HDD as they were being updated. It could probably do with some error trapping...

Now for those MUI updates I spied as well.
User avatar
daveyw
 
Posts: 144
Joined: Mon Sep 12, 2011 8:44 pm


Return to Platform: AmigaOne XE and MicroA1-C

Who is online

Users browsing this forum: No registered users and 4 guests

cron