Installation on A4000 with GRex

A forum for Classic Amiga specific support issues.

Installation on A4000 with GRex

Postby Alexco » Tue Jun 21, 2016 7:36 am

Hi all,

I successfully installed AOS 4.1 FE on my Amiga4000 with GRex. Installation went smooth and the box is stable.
For AmigaOS 3.9 and MorphOS PowerUp I have a Voodoo 3 and a Permedia 2 with 8MB (an old Elsa PC card) installed. I can use both cards in both systems without any issues.
But to use a graphics card with OS4 FE I had to remove the other one. When both cards are installed, AmigaOS4 does not recognize any card, and you can't configure anything using P96Mode or ScreenMode.
If only the Voodoo is installed, everything can be done using ScreenMode only.
If the Permedia 2 card is installed, I need to configure the screen modes using P96Mode, before I can select the correct screen with Screen Mode.
For this I had to find a P96 settings file in the internet (on A1k.org Ratte provides a general purpose file which provides all Vesa modes).
Why not include such a file? Or am I missing something?

Regards,
Alexander
Alexco
 
Posts: 6
Joined: Sun Jun 05, 2016 10:35 am

Re: Installation on A4000 with GRex

Postby SimonV » Tue Aug 09, 2016 5:57 pm

I have a blizzard PPC with GREX and voodoo ... I wonder if OS4 is going to work.
SimonV
 
Posts: 2
Joined: Thu Nov 19, 2015 12:09 am

Re: Installation on A4000 with GRex

Postby Alexco » Sat Aug 20, 2016 11:36 am

Should work, as long as you do not use more than one GFX card.
Alexco
 
Posts: 6
Joined: Sun Jun 05, 2016 10:35 am

Re: Installation on A4000 with GRex

Postby DarrenHD » Tue Aug 30, 2016 7:11 am

SimonV wrote:I have a blizzard PPC with GREX and voodoo ... I wonder if OS4 is going to work.


Yes it should work. GREX support is experimental but that config was tested (Blizzard+grex+voodoo).
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: Installation on A4000 with GRex

Postby DarrenHD » Tue Aug 30, 2016 7:12 am

Alexco wrote:Hi all,

I successfully installed AOS 4.1 FE on my Amiga4000 with GRex. Installation went smooth and the box is stable.
For AmigaOS 3.9 and MorphOS PowerUp I have a Voodoo 3 and a Permedia 2 with 8MB (an old Elsa PC card) installed. I can use both cards in both systems without any issues.
But to use a graphics card with OS4 FE I had to remove the other one. When both cards are installed, AmigaOS4 does not recognize any card, and you can't configure anything using P96Mode or ScreenMode.
If only the Voodoo is installed, everything can be done using ScreenMode only.
If the Permedia 2 card is installed, I need to configure the screen modes using P96Mode, before I can select the correct screen with Screen Mode.
For this I had to find a P96 settings file in the internet (on A1k.org Ratte provides a general purpose file which provides all Vesa modes).
Why not include such a file? Or am I missing something?

Regards,
Alexander


Bottom line is that, unfortunately, two PCI graphic cards are not supported on AmigaOS 4.x Classic. It's in the FAQ. It's likely due to address space limitations. OS4 uses more address space than 3.x and there just isn't enough of it on the Classic.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: Installation on A4000 with GRex

Postby Alexco » Mon Jan 16, 2017 11:21 pm

DarrenHD wrote:Bottom line is that, unfortunately, two PCI graphic cards are not supported on AmigaOS 4.x Classic. It's in the FAQ. It's likely due to address space limitations. OS4 uses more address space than 3.x and there just isn't enough of it on the Classic.


Just a quick note to this issue. Since the 2 PCI cards work in OS3 and MOS 1.4.5 without issues, is there maybe a way to block a 2nd PCI GFX card so that it is no longer available on the bus (a.k.a. "shut up")?
Alexco
 
Posts: 6
Joined: Sun Jun 05, 2016 10:35 am

Re: Installation on A4000 with GRex

Postby DarrenHD » Mon Jan 16, 2017 11:34 pm

Alexco wrote:
DarrenHD wrote:Bottom line is that, unfortunately, two PCI graphic cards are not supported on AmigaOS 4.x Classic. It's in the FAQ. It's likely due to address space limitations. OS4 uses more address space than 3.x and there just isn't enough of it on the Classic.


Just a quick note to this issue. Since the 2 PCI cards work in OS3 and MOS 1.4.5 without issues, is there maybe a way to block a 2nd PCI GFX card so that it is no longer available on the bus (a.k.a. "shut up")?


I'm sure it is doable, but unfortunately not that high on the priority list I am afraid. I agree it is annoying having to swap in/out PCI cards, like if you want Warp3D support on OS 3.9 you have to remove your Radeon PCI (which ironically has Warp3D and composting support in AmigaOS 4.1 Classic...

Anyway, another way around it is to get a Warp3D driver written for OS 3.x ;=)
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada


Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 0 guests

cron