no way back

A forum for general AmigaOS 4.x support questions that are not platform-specific

no way back

Postby djg » Thu Apr 12, 2018 7:03 pm

Shouldn't commands like NetShutDown and Reboot do nothing when called with a question mark with nothing entered?
I think a command that will do something as drastic as rebooting should at least ask if you are sure, or otherwise be called with something like Reboot FORCE or Reboot RIGHTNOW.
djg
 
Posts: 22
Joined: Sat Jan 26, 2013 6:00 pm

Re: no way back

Postby salass00 » Fri Apr 13, 2018 10:36 am

For "Reboot ?" at least you can stop it from rebooting by pressing CTRL-C before RETURN.
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 506
Joined: Sat Jun 18, 2011 4:12 pm
Location: Finland

Re: no way back

Postby djg » Fri Apr 13, 2018 11:24 am

salass00 wrote:For "Reboot ?" at least you can stop it from rebooting by pressing CTRL-C before RETURN.


Did not think of that. Thanks.
djg
 
Posts: 22
Joined: Sat Jan 26, 2013 6:00 pm

Re: no way back

Postby xenic » Fri Apr 13, 2018 4:10 pm

salass00 wrote:For "Reboot ?" at least you can stop it from rebooting by pressing CTRL-C before RETURN.

Wouldn't it be better to submit a bug report requesting that reboot put up a requester unless a FORCE option is used (as suggested by djg).

In addition, I think that all the non-standard commands in SYS:C need to be updated with ReadArgs and templates so that all commands respond to "?" as expected on an Amiga.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1146
Joined: Sun Jun 19, 2011 1:06 am

Re: no way back

Postby Amigo1 » Thu Apr 19, 2018 10:20 pm

xenic wrote:
salass00 wrote:For "Reboot ?" at least you can stop it from rebooting by pressing CTRL-C before RETURN.

Wouldn't it be better to submit a bug report requesting that reboot put up a requester unless a FORCE option is used (as suggested by djg).

In addition, I think that all the non-standard commands in SYS:C need to be updated with ReadArgs and templates so that all commands respond to "?" as expected on an Amiga.


After more than a year, maybe a few, I recently played around with an A1200. I had forgotten how modern OS3.9 feels like, for it's age, and I was quite impressed. But after a couple of hours, I had to copy some files from the A1X1k to the CF card and without any doubt OS4.1FEu1 feels so much more advanced, snappy and polished. It really feels like home, a souped up home. All the devs did a good job improving the OS quite a lot.

But there sure are some, for lack of a better word, incomprehensible inconsistencies. This is one these, and quite annoying. :?

I fully share your opinion. :| :!:
User avatar
Amigo1
 
Posts: 179
Joined: Sun Jan 01, 2012 4:32 pm


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 3 guests